24Pet Professional Portal - Animals Registered to Pet Owners not setting Reunification Contact
Incident Report for Pethealth Software Solutions
Resolved
This incident has been resolved.
Posted Dec 15, 2022 - 14:55 EST
Identified
The Pethealth development teams have discovered that animals registered through the 24Pet Professional Portal to their Pet Owners are not connecting the organizations contact information as a Reunification Contact. Our development teams are working to address this issue and are setting up processes to update records that have already been created in the 24Pet Professional Portal. Thank you for your patience as we work to address this issue.
Posted Nov 08, 2022 - 12:52 EST
This incident affected: 24Pet (Pet Professional Portal).