PetPoint Emergency Support Only - 5/16 thru 5/20/22
Incident Report for Pethealth Software Solutions
Resolved
Thank you for your support of Pethealth's Software Solutions mandatory training. Your software services support staff have returned to their regular support hours to include web form support for all our shelter partners and live chat and phone support available to our Enhanced Support shelter partners from 9 am - 6 pm Eastern (excluding US Holidays). Thank you again for your patience as we work to catch up on the non-emergency support cases that were submitted while our staff was in mandatory training.
Posted May 23, 2022 - 09:04 EDT
Monitoring
The PetPoint Support Team will be in mandatory training from May 16 - May 20, 2022. Emergency PetPoint support will be available during this time period, and any non-Emergency related questions or issues will be addressed the week of May 23rd, 2022. Thank you for your support of this important training opportunity.
Posted May 15, 2022 - 21:39 EDT
This incident affected: Support Options (PetPoint Support).