PetPoint is experiencing Technical Difficulties resulting in overall slowness
Incident Report for Pethealth Software Solutions
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 17:35 EST
Monitoring
A fix has been implemented and PetPoint is running as expected. We are monitoring the situation.
Posted Nov 30, 2022 - 15:44 EST
Investigating
The PetPoint application is currently experiencing technical difficulties with slowness. We are investigating the cause for this and will provide an update as soon as possible.
Posted Nov 30, 2022 - 15:03 EST
This incident affected: PetPoint (PetPoint Application).