24Pet Professional Portal - Reunification Contact not showing accurately
Incident Report for Pethealth Software Solutions
Resolved
This incident has been resolved.
Posted Dec 15, 2022 - 14:54 EST
Investigating
The 24Pet Professional Portal is aware of an issues where animals registered to Pet Parents may not be displaying the reunification contact. This is a technical issue related to display only; organizations listed as reunification contacts will still receive notifications in the event an animal is lost and found. We are working to correct this display error.
Posted Nov 02, 2022 - 14:45 EDT
This incident affected: 24Pet (Pet Professional Portal).