24Pet Professional Portal - Batch Uploads Sporadic Issues
Incident Report for Pethealth Software Solutions
Resolved
This incident has been resolved.
Posted Dec 15, 2022 - 14:55 EST
Investigating
Our development teams have discovered that batch uploads to the 24Pet Professional Portal has resulted in a small number of microchips not transferring ownership as per the data in the files. We have received reports from a few organizations that have experienced this sporadically. In the unlikely event you experience this issue, please reach out to clientcare@pethealthinc.com.
Posted Oct 27, 2022 - 16:48 EDT
This incident affected: 24Pet (Pet Professional Portal).