PetPoint: Petfinder Auto-Uploads

Incident Report for 24Pet Software Solutions

Identified

Some organizations have reported data not feeding from PetPoint to Petfinder. This is an ongoing issue and the Development team is working on a correction.
If your organization is being affected by this issue, please create a Support Case so we can track reports.
Updates will be posted here as they become available.
Posted Sep 21, 2026 - 12:29 EDT
This incident affects: Online Animal Listings (PetPoint) (Petfinder).