Maintenance to Community

Identified

The is currently maintenance being performed on the Community site. Thank you for your patience while we work on improving this site.
If you need to access Support but cannot access Community, please use the URL below until the maintenance has been completed.

https://services.24pet.com/24Petcare/Support.php?

Updates will be posted here as the become available.
Posted Jan 27, 2026 - 16:58 EST
This incident affects: Support Options (Pethealth Community).