Animal Search Updates Extremely Delayed

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 08:48 EST

Monitoring

A fix has been implemented and we are monitoring the results.
At this time the Animal Search is updating in a timely fashion.
Posted Dec 18, 2025 - 15:40 EST

Investigating

We have received several reports that updates to the Animal Search are severely delayed.
We are investigating the issue and updates will be posted here as they become available.

Thank you for your patience.
Posted Dec 18, 2025 - 14:58 EST
This incident affected: PetPoint (PetPoint Application).