PetPoint Performance Slow

Update

We are continuing to monitor for any further issues.
Posted Feb 26, 2026 - 18:07 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2026 - 18:07 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 26, 2026 - 16:56 EST

Identified

Some users may be experiencing slower response times in PetPoint. Our team is working to resolve the issue. Updates will posted as they are received. Thank you!
Posted Feb 26, 2026 - 16:56 EST
This incident affects: PetPoint (PetPoint Application).