Pet Professional Portal: Photos not displaying after saved

Incident Report for Pethealth Software Solutions

Update

We are continuing to investigate this issue.
Posted Mar 12, 2025 - 10:32 EDT

Update

We are continuing to investigate this issue.
Posted Mar 05, 2025 - 10:01 EST

Investigating

We have received reports of users adding and saving photos to animal records, but the photos are not displayed in the animal grid. Our development teams are investigating the cause of this issue, and we hope to provide an update soon. Thank you for your patience!
Posted Feb 28, 2025 - 18:18 EST
This incident affects: 24Pet (Pet Professional Portal).