Software Support Holiday Hours - Memorial Day (US)

Resolved

Normal business hours have resumed.
Posted May 26, 2026 - 08:52 EDT

Monitoring

Software Support will be CLOSED Monday May 25th.
Normal business hours will resume on Tuesday May 26th.

The Enhanced Support Emergency phone line will be monitored during this time.
Posted May 22, 2026 - 11:02 EDT
This incident affected: PetPoint (PetPoint Application), 24Pet (Pet Assistant, Pet Professional Portal, 24Petconnect), Chameleon (Chameleon), EVE for Clinics, 24PetShelter, 24PetRescue, and Support Options (PetPoint Support).