Pet Professional Portal Save Issues

Resolved

This issue has been resolved. All registered pets should be displaying on the dashboard at this time. If you do not see a specific pet, please try registering the microchip again. If you continue to have issues, please reach out with detail about what you are experiencing. Thank you!
Posted Aug 31, 2026 - 17:17 EDT

Identified

We have received reports of users being unable to view pets after they are registered. As a result, users are unable to edit and/or transfer animal records at this time.
Our development teams are investigating the cause of this issue, and we hope to provide an update shortly. In the meantime, you can contact our call center at 1- 833-714-5866 to complete your registrations. Thank you for your patience!
Posted Aug 31, 2026 - 12:49 EDT
This incident affected: 24Pet (Pet Professional Portal).