PetPoint Builder Performance Issue

Incident Report for 24Pet Software Solutions

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2026 - 15:53 EDT

Investigating

Access to PetPoint Enterprise Builders is currently unavailable or experiencing technical difficulties. We are investigating the cause for this and will provide an update as soon as possible.
Posted Sep 03, 2026 - 15:25 EDT
This incident affects: PetPoint (Builders Add-On).