Software Support Holiday Hours - Juneteenth

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 09:27 EDT

Monitoring

Software Support will be CLOSED Friday, June 19th
Normal business hours will resume on Monday, June 22nd

The Enhanced Support Emergency phone line will be monitored during this time.
Posted Jun 18, 2026 - 09:40 EDT
This incident affected: PetPoint (PetPoint Application), 24Pet (Pet Assistant, Pet Professional Portal, 24Petconnect), Chameleon (Chameleon), and EVE for Clinics, 24PetShelter, 24PetRescue.