PetPoint Mobile Checkout Errors

Incident Report for Pethealth Software Solutions

Resolved

This issue has been resolved. If your team or customers are still encountering errors within the Mobile Checkout functionality, please reach out to Software Support.
Posted Sep 04, 2025 - 14:55 EDT

Identified

The PetPoint Mobile Checkout functionality is experiencing error messages on the customer side. Our team is working to correct this issue, and we will post updates as soon as possible.
Posted Sep 02, 2025 - 17:08 EDT
This incident affected: PetPoint (Mobile Checkout).