PetPoint Intermittent Refund Error

Investigating

We have received several reports of an error message when processing a refund with an integrated payment processor (Bluefin or Stripe). This issue is intermittent and does NOT occur with every refund.

When it does occur, the refund IS processed in the payment processor, but is not recorded in PetPoint. One workaround is to process the refund in PetPoint as a different payment type (such as Debit Card instead of Credit Card) to record the refund.

Please reach out to the Support team if you need additional assistance.

Updates will be posted here as they become available.
Posted Feb 06, 2026 - 11:36 EST
This incident affects: PetPoint (PetPoint Application) and Integrations (PetPoint) (Bluefin).