Possible Slowness to Load PetPoint

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 15:44 EDT

Monitoring

Please let us know if you are still experiencing slowness issues. Thank you.
Posted Aug 31, 2026 - 12:10 EDT

Investigating

We are receiving information about possible slowness in PetPoint. The team is looking into these issues.
Posted Aug 31, 2026 - 11:38 EDT
This incident affected: PetPoint (PetPoint Application).