PetPoint Builder Performance Issue
Incident Report for Pethealth Software Solutions
Resolved
This incident has been resolved.
Posted May 18, 2022 - 10:10 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2022 - 08:02 EDT
Investigating
Execution of PetPoint Enterprise Builders and Documents is currently experiencing technical difficulties. We are investigating the cause for this and will provide an update as soon as possible.
Posted May 18, 2022 - 07:44 EDT
This incident affected: PetPoint (Builders Add-On).