Software Support Holiday Hours - MLK Jr.

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 08:47 EST

Monitoring

Software Support will be CLOSED Monday January 19th, 2026.
Normal business hours will resume on Tuesday January 20th.

The Enhanced Support Emergency phone line will be monitored during this time.
Posted Jan 16, 2026 - 08:43 EST
This incident affected: Support Options (PetPoint Support).