24PetRescue: 502 Gateway error

Resolved

This incident has been resolved.
Posted May 29, 2026 - 13:49 EDT

Investigating

We have received reports of a 502 Gateway error in 24PetRescue.
We are investigating the cause and a solution.
Updates will be posted here as they become available.
Posted May 29, 2026 - 11:10 EDT
This incident affected: 24PetRescue.