A fix has been implemented and we are monitoring the results. At this time, new Animal records are displaying on the Home Screen/ Search Index and are able to located using the search.
Additional updates will be posted here as they become available. Thank you for your patience.
Posted Nov 05, 2025 - 13:21 EST
Update
We are continuing to investigate this issue. It seems to be limited to Animal records at this time. New Animal records are not able to be located in the search. Person, Intake, and other searches seem to be working as expected. New Animal records can be viewed and accessed in the My Recent Records page.
We are still investigating the underlying cause and a correction. Updates will be posted as they become available.
Posted Nov 05, 2025 - 09:52 EST
Investigating
We have received reports that new records (Animal, Person, Intake, etc.) created in PetPoint are unable to be searched. These records are displaying on the My Recent Records page (clock icon in the top right corner of the home screen) at this time. We are investigating this issue and updates will be posted here as they become available.
Thank you for your patience.
Posted Nov 05, 2025 - 09:37 EST
This incident affected: PetPoint (PetPoint Application).