PetPoint: Stripe Payment Processing Errors

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2025 - 13:14 EST

Investigating

We have received several reports of intermittent errors occurring with Stripe Payment Processing that are preventing payment from being processed.
The error messages themselves vary and are not consistent. The Development team is investigating and working on a solution. Updates will be posted here as they become available.

Thank you for your patience.
Posted Nov 10, 2025 - 11:22 EST
This incident affects: PetPoint (PetPoint Application, Mobile Checkout).