PetPoint Enhanced Support Chat Outage

Resolved

The Enhanced Support Chat option is now operational.
Thank you for your patience while we corrected this issue.
Posted Apr 17, 2026 - 09:53 EDT

Investigating

We have received reports that the PetPoint Enhanced Support Chat option is not operating as expected.
We are investigating the issue and updates will be posted here as they become available.
The Enhanced Support Phone line and all Case submission forms are unaffected at this time.

Thank you for your patience.
Posted Apr 10, 2026 - 14:32 EDT
This incident affected: Support Options (PetPoint Support).