PetPoint: Performance Issues

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 11:58 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2025 - 15:17 EST

Investigating

We are currently experiencing slow processing times and errors in PetPoint. We are investigating the cause for this and will provide an update as soon as possible.
Posted Nov 13, 2025 - 14:48 EST
This incident affected: PetPoint (PetPoint Application).