Support > Contact Us is experiencing technical issues

Incident Report for Pethealth Software Solutions

Update

The Support case submission form is now working.
We are continuing to work on restoring the Chat for our Enhanced Support users.
Posted Apr 03, 2025 - 10:05 EDT

Investigating

Users will see an error when trying to submit a Support case from Community. For our Enhanced Support users, this also means that Chat is unavailable until this error has been resolved. For PetPoint outages or other similar emergencies, please use the Enhanced Support phone line.
Posted Apr 03, 2025 - 08:48 EDT
This incident affects: Support Options (PetPoint Support).