24PetConnect Outage

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 15:10 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Chameleon organizations utilizing Knowledge Rocket 3 for online pet listings may still be experiencing interruption.

Thank you for your patience.
Posted Jan 23, 2026 - 08:22 EST

Identified

We have identified the underlying issue and are working on a fix.
The current known systems impacted are ChameleonBeach, 24Petconnect, Petplace, WebLicensing, VetImport, ImageEntry, ChipLookup.
These Sites are all up, but will not update until this is resolved. Animal listings on 24Petconnect and PetPlace are completely down at this time.
We have also been notified that shelter website RSS feeds as well as Pawboost, PetcoLoveLost, Adopt-A-Pet, and Petsmart AME RSS feeds are also down.

Updates will be posted here as they become available.
Thank you for your patience.
Posted Jan 22, 2026 - 08:39 EST

Investigating

24PetConnect is currently experiencing an outage. Any websites associated with 24Petconnect are also being affected including, but not limited to, Chameleon web licensing and ChameleonBeach.
Updates will be posted here as they become available.
Posted Jan 21, 2026 - 17:51 EST
This incident affected: 24Pet (24Petconnect).