Pet Professional Portal Outage

Resolved

This incident has been resolved.
Posted May 28, 2026 - 09:06 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2026 - 11:52 EDT

Investigating

We have received reports that the Pet Professional Portal is down.
We are investigating the issue and updates will be posted here as they become available.

Thank you for your patience.
Posted May 27, 2026 - 11:21 EDT
This incident affected: 24Pet (Pet Professional Portal).