Issue with PetPoint to Petfinder auto-uploads

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 10:46 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 22, 2026 - 10:52 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 09:28 EDT

Investigating

Our team is currently investigating an issue where the auto-uploads from PetPoint to Petfinder are not working for some organizations. This means the listings of adoptable animals showing on Petfinder may be out of date. We will post updates as they are received. For additional information about Petfinder, please visit their Status Page here: https://help.petfinder.com/s/topic/0TO2J000000R2sIWAS/petfinder-site-status-page
Posted Mar 26, 2026 - 14:25 EDT
This incident affected: Online Animal Listings (PetPoint) (Petfinder).