Issues within Mobile Checkout

Incident Report for Pethealth Software Solutions

Identified

Currently we are experiencing issues within Mobile Checkout. Most issues appear to be related to including Animal Files. At this time, including Animal Files on Mobile Checkout is causing delivery issues. Excluding the Animal Files will allow for timely delivery of documents to customers.
The underlying cause has been identified, and the Development team is working on a correction.

Updates will be posted here as they become available.
Posted Jun 27, 2025 - 12:07 EDT
This incident affects: PetPoint (Mobile Checkout).