Builders Issues

Incident Report for Pethealth Software Solutions

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 15:03 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2025 - 14:29 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 06, 2025 - 13:59 EST
This incident affected: PetPoint (Builders Add-On).