Issue with Scheduled Medical Items with Auto-Triggers

Incident Report for Pethealth Software Solutions

Monitoring

The correction has been released and we are monitoring the results.
Thank you for you patience.
Posted Aug 21, 2025 - 09:01 EDT

Update

The Development team is hoping to have the correction for this issue released by the end of this week.
Updates will continue to be posted here as they become available.

Thank you for your patience.
Posted Aug 19, 2025 - 15:31 EDT

Identified

The Development team has identified the cause of the issue and is working on a correction.
Updates will be posted here as they become available.

Thank you for your continued patience.
Posted Aug 14, 2025 - 09:07 EDT

Investigating

We have received several reports of Scheduled Medical Items not receiving a default Review Date or auto-triggering the next Item as setup when updated from Scheduled to Completed and are investigating further.

Updates will be posted here as they become available.
Thank you for your patience.
Posted Aug 13, 2025 - 16:20 EDT
This incident affects: PetPoint (PetPoint Application).