Pet Assistant: App not available for use with Android

Incident Report for Pethealth Software Solutions

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 07:45 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 13, 2025 - 09:12 EST

Investigating

We have received reports of the Pet Assistant app not being available for use/download on Android devices. We have alerted our team and will post updates here as they are received.
Posted Dec 12, 2024 - 09:59 EST
This incident affected: 24Pet (Pet Assistant).