24Petconnect.com/PetPlace.com: Adoptable Animal Listings not updating as expected

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 09:30 EDT

Identified

The issue has been identified, and our team is working to resolve the underlying cause for the delay in updates to the online animal listings. We will post additional updates here as they are received. Thank you!
Posted Jul 23, 2026 - 14:22 EDT

Investigating

There is an issue with the 24Petconnect.com/PetPlace.com adoptable animal listings not updating as expected. We will post updates here as they are received. Thank you!
Posted Jul 23, 2026 - 11:35 EDT
This incident affected: 24Pet (24Petconnect) and Online Animal Listings (PetPoint) (PetPlace.com Adoptable Animal Listings).