PetPoint Performance Issues

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 17:14 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 09:18 EST

Identified

The issue has been identified, and the fix will be implemented after 9.00 pm EST.
Posted Dec 02, 2025 - 18:07 EST

Investigating

We are currently experiencing slow processing times and Error 500 screens in PetPoint. We are investigating the cause for this and will provide an update as soon as possible.
Posted Dec 02, 2025 - 16:44 EST
This incident affected: PetPoint (PetPoint Application).