Pet Professional Portal Outage

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 16:03 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 15:47 EDT

Investigating

We have received reports of interrupted service to the Pet Professional Portal.
We are working to resolve this issue and updates will be posted here as they become available.

Thank you for your patience.
Posted Jun 29, 2026 - 15:07 EDT
This incident affected: 24Pet (Pet Professional Portal).