PetPoint Performance Slowness and Login Issues
Incident Report for Pethealth Software Solutions
Resolved
We have received verification from our infrastructure provided, Microsoft Azure, that they have identified and have corrected the issue that ultimately effected access to PetPoint:

From Microsoft Azure Support: Engineers have identified the underlying root cause as an incorrect name server delegation issue affecting DNS resolution, network connectivity, and downstream impact to Compute, Storage, App Service, AAD, and SQL Database resources. Mitigation has been applied, and the majority of Azure and other Microsoft services have recovered. We are in the process of final validation to ensure full recovery.

We are confident that any additional access to PetPoint issues has now been resolved. Thank you again for your patience!
Posted May 02, 2019 - 19:28 EDT
Monitoring
We have been able to verify that a number of our clients are now able to access PetPoint. The reason for the outage was due to our infrastructure service provider, Microsoft Azure, experiencing a global issue with their storage services. Microsoft Azure is still identifying they are experiencing issues. We are currently monitoring the situation and will resolve this status page once we receive verification from Microsoft Azure. Thank you for your patience!
Posted May 02, 2019 - 17:10 EDT
Identified
We have identified this issue as a global issue affecting all Microsoft hosted sites. We are working to get this addressed as soon as possible. We apologize for any inconvenience.
Posted May 02, 2019 - 17:01 EDT
Investigating
We are currently experiencing issues with some users logging into the database and slow processing times in PetPoint. We are investigating the cause for this and will provide an update as soon as possible.
Posted May 02, 2019 - 16:04 EDT
This incident affected: PetPoint (PetPoint Application).