All of the system interruptions through the hardware outage are fully resolved - including Chiplet and ChamTransfer!
Thank you for your patience!
Posted Jan 23, 2026 - 15:09 EST
Update
We have been notified that Chiplet/Microchip Lookup and ChamTransfer are still down. Updates will continue to be posted here as they become available.
Posted Jan 23, 2026 - 11:46 EST
Monitoring
A fix has been implemented and we are monitoring the results. Chameleon organizations utilizing Knowledge Rocket 3 for online pet listings may still be experiencing interruption.
Thank you for your patience.
Posted Jan 23, 2026 - 08:21 EST
Update
We’re currently experiencing a service interruption, and as a result, the following services are temporarily unavailable:
Adoptable pet search on PetPlace.com and 24PetConnect.com Lost & Found search on 24PetConnect.com Several Chameleon-related tools, including: ChameleonBeach WebLicensing VetImport ImageEntry ChipLookup in Chameleon PossiblePeople ChamTransfer Animal Service Request WebDonation
Our technology team has confirmed this is a hardware issue and is actively working to either repair or replace the affected equipment as quickly as possible. This is a top priority because we know these tools are essential to daily operations for our partners and our internal teams. We appreciate everyone’s patience and flexibility as we work through this. We’ll continue to share updates as we learn more and as progress is made toward resolution.
Posted Jan 22, 2026 - 15:57 EST
Identified
The issue has been identified, and our team is working on a resolution. Updates will be posted as they are received.