Support > Contact Us is experiencing technical issues

Incident Report for Pethealth Software Solutions

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 10:44 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2025 - 16:40 EDT

Investigating

Users will see an error when trying to submit a Support case from Community. For our Enhanced Support users, this also means that Chat is unavailable until this error has been resolved. For PetPoint outages or other similar emergencies, please use the Enhanced Support phone line.
Posted Apr 21, 2025 - 15:50 EDT
This incident affected: Support Options (PetPoint Support).