PetPoint Community

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 16:21 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2026 - 13:22 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 23, 2026 - 12:03 EST

Investigating

Access to PetPoint Community through PetPoint is currently unavailable. Previous links to Community may also be unavailable.
While we work to correct this issue, you may be able to access Community using this URL: https://pethealth.my.site.com/community/s/ . If you are logged into PetPoint and paste the link into your browser window it should not ask for credentials.

If you need to open a Support Case please use the external contact form found at https://services.24pet.com/24Petcare/Support.php? .

Thank you for your patience.
Posted Feb 23, 2026 - 11:04 EST
This incident affected: Support Options (Pethealth Community).