Pet Professional Portal - Some photos are displayed as a broken image
Incident Report for Pethealth Software Solutions
Update
Some animal photos may be displayed as a broken image icon in the Search grid. Our development team will be investigating the cause for this issue. Updates will be posted here as they are received. Thank you for your patience!
Posted Sep 12, 2024 - 08:22 EDT
Update
Some animal photos may be displayed as a broken image icon in the Search grid. Our development team will be investigating the cause for this issue. Updates will be posted here as they are received. Thank you for your patience!
Posted Aug 05, 2024 - 10:47 EDT
Investigating
Some animal photos may be displayed as a broken image icon in the Search grid. Our development team will be investigating the cause for this issue. Updates will be posted here as they are received. Thank you for your patience!
Posted Jul 26, 2024 - 08:28 EDT
This incident affects: 24Pet (Pet Professional Portal).