PetPoint - Long Load Times and 500 Errors

Incident Report for Pethealth Software Solutions

Monitoring

The Development team has identified the issue and released a correction. We are monitoring the results at this time.
Thank you for your patience.
Posted Apr 18, 2025 - 14:49 EDT

Investigating

We have received a handful of reports of long load times and 500 errors within PetPoint and are investigating the cause and a correction. Updates will be posted here as they become available.
Posted Apr 18, 2025 - 14:45 EDT
This incident affects: PetPoint (PetPoint Application).