PetPoint Animal View Report - Technical Difficulties
Incident Report for Pethealth Software Solutions
Resolved
This incident has been resolved.
Posted May 11, 2022 - 16:23 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 11, 2022 - 10:21 EDT
Update
We are continuing to investigate this issue.
Posted May 11, 2022 - 09:33 EDT
Investigating
The PetPoint Animal View Report is currently experiencing technical difficulties. We are investigating the cause for this and will provide an update as soon as possible.
Posted May 11, 2022 - 08:20 EDT
This incident affected: PetPoint (Reports).