PetPoint: Some users may experience errors when using Support>Community it Support>Contact Us from within PetPoint

Incident Report for 24Pet Software Solutions

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 12:04 EDT

Investigating

We have received reports of some users being unable to access Community or the Support webform via Support>Community and Support>Contact Us from within PetPoint.

At this time this issue does not appear to be affecting all users and we are working to identify and correct the issue.

If you encounter this issue and need to submit a support case, please use the external support form found at https://services.24pet.com/24Petcare/Support.php? .

Updates will be posted here as they become available.
Posted Sep 14, 2026 - 14:21 EDT
This incident affected: Support Options (Pethealth Community, PetPoint Support).