Enhanced Support - Technical issues with Live Chat

Monitoring

A fix has been implemented and we are monitoring the results.

Thank you for your patience.
Posted Nov 24, 2025 - 08:54 EST

Investigating

Enhanced Support - Live Chat is experiencing technical issues on the Agent side and will not be available until the issue has been resolved. In the meantime, the Support webform and the Enhanced Support phone line are available.
Posted Nov 21, 2025 - 14:45 EST
This incident affects: Support Options (PetPoint Support).