PetPoint Enhanced Support Chat Outage

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 18:42 EDT

Identified

Chat is currently available via the main page of Community (Support>Community from within PetPoint). However, it is not available when using Contact Us (Support>Contact Us from within PetPoint).

We are working to correct this issue and updates will be posted here as they become available.
Thank you for your patience.
Posted Apr 21, 2026 - 15:33 EDT

Investigating

We have received reports that the PetPoint Enhanced Support Chat option is not operating as expected.
We are investigating the issue and updates will be posted here as they become available.
The Enhanced Support Phone line and all Case submission forms are unaffected at this time.
Posted Apr 21, 2026 - 15:23 EDT
This incident affected: Support Options (PetPoint Support).