Pet Profession Portal Outage

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 08:15 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2026 - 18:48 EDT

Investigating

We have received several reports of an outage affecting the Pet Professional Portal. At this time users are able to login but all dashboards are blank and 0 animals display.
We are investigating the cause and a solution.
Updates will be posted here as they become available.
Posted Sep 01, 2026 - 18:33 EDT
This incident affected: 24Pet (Pet Professional Portal).