PetPoint Contact US Support Submission Form
Incident Report for Pethealth Software Solutions
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 16:45 EST
Investigating
We have received reports of users being unable to access and submit the Support Submission form from within PetPoint (Support>Contact Us). At this time this seems to be an intermittent issue and may be primarily affecting Enterprise groups.

If you need to submit a support case and are unable to access the form, please use this external URL to do so: https://services.24pet.com/Support/

We are investigating this issue and updates will be posted here as they become available.
Posted Nov 15, 2024 - 15:58 EST
This incident affected: Support Options (PetPoint Support).