PetPoint Support Case Error Message

Resolved

This incident has been resolved.
Thank you for your patience.
Posted Nov 25, 2025 - 12:03 EST

Update

While we are investigating this issue, you should still be able to submit a Support Case through this external support link: https://services.24pet.com/24Petcare/Support.php? .
At this time, Enhanced Support phone line and chat are still working as expected.
Posted Nov 25, 2025 - 11:57 EST

Investigating

We have received reports of users receiving an error message when attempting to submit a new Support Case.
We are investigating the issue and updates will be posted here as they become available.
Posted Nov 25, 2025 - 11:53 EST
This incident affected: Support Options (PetPoint Support).