PetPoint Loading Errors

Resolved

The Microsoft Azure platform issues were resolved around 8pm Eastern last night and we monitored through the night.
At this time PetPoint is operational.

Thank you for your patience.
Posted Oct 30, 2025 - 08:35 EDT

Update

Microsoft is expecting to have a full recovery within the next 4 hours.
Access to PetPoint may be intermittent until the recovery is complete.

Additional updates will be posted here as they become available.
Posted Oct 29, 2025 - 15:58 EDT

Identified

Microsoft has been rolling out updates to the Azure platform to mitigate the issues on their end.
Some users may now be able to access PetPoint without issue. If you are currently unable to access PetPoint, please keep trying periodically as the updates are rolling out.

Updates will be posted here as they become available. Thank you for your patience.
Posted Oct 29, 2025 - 15:36 EDT

Update

We continue to wait for updates from Microsoft Azure regarding this issue. Some users may be able to access PetPoint, however it is limited and you may encounter loading issues.
Posted Oct 29, 2025 - 15:00 EDT

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 14:09 EDT

Update

Our Dev Team is in communication with MS Azure regarding this outage. Once further information is provided from MS Azure we will provide updates. Thank you for your patience.
Posted Oct 29, 2025 - 12:39 EDT

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 12:15 EDT

Investigating

We are currently investigating issue with PetPoint loading, along with standard kennel cards and reports
Posted Oct 29, 2025 - 12:12 EDT
This incident affected: PetPoint (PetPoint Application, Builders Add-On), Online Animal Listings (PetPoint) (Adoptable Animals IFrame), and 24Pet (Pet Professional Portal).