PetPoint Builder Performance Issue

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 25, 2026 - 18:19 EDT

Investigating

Access to PetPoint Enterprise Builders is currently unavailable or experiencing technical difficulties. We are investigating the cause for this and will provide an update as soon as possible.
Posted Aug 25, 2026 - 18:11 EDT
This incident affects: PetPoint (Builders Add-On).